Back to overview
Downtime

Users are having trouble connecting to Discord

Mar 10 at 08:11pm CET
Affected services
Discord (Web App)

Resolved
Mar 10 at 08:20pm CET

Resolved - This incident has been resolved.

Updated
Mar 10 at 08:17pm CET

Identified - The issue has been identified and a fix is being implemented.
Mar 10, 2025 - 12:03 PDT

Created
Mar 10 at 08:11pm CET

Investigating - We are currently investigating this issue.
Mar 10, 2025 - 11:57 PDT